AudioStreamer Forums Support failed to start Mongoose…

This topic contains 6 replies, has 3 voices, and was last updated by  busybusy 4 years, 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #395

    g2c
    Participant

    Hello,

    When launching AudioStreamer i am getting “failed to start Mongoose. Maybe some options are assigned bad values? …”

    When i run AudioSteamer from elevated command prompt with -e (only) param I am getting :”[1414046550] [error] [client 0.0.0.0] set_ports_option: cannot bind to 9090: No error”

    Can someone please help me?

    Thanks for your time

    Windows 7

    #428

    g2c
    Participant

    Hello,

    When launching AudioStreamer i am getting “failed to start Mongoose. Maybe some options are assigned bad values? …”

    When i run AudioSteamer from elevated command prompt with -e (only) param I am getting :”[1414046550] [error] [client 0.0.0.0] set_ports_option: cannot bind to 9090: No error”

    Can someone please help me?

    Thanks in advance for your time

    Windows 7

    #429

    Lieven Rottiers
    Moderator

    Hi,

    The error: “cannot bind to 9090” usually means there is some other program running on port 9090.
    This program might be another AudioStreamer.exe that’s already started or some other program using the same port.

    Can you close/terminate these programs and retry?

    Regards,
    Lieven

    #430

    g2c
    Participant

    Thanks, indeed I had 2 instances. The issue is closed now.

    I do have difficulties with android but will open another thread

    Many thanks again,

    #590

    busybusy
    Participant

    Found and interesting but not so fix. Note, even though the program emits an error after first running AudioStreamer.exe it is actually running in the Taskbar.

    Right-click on the AudioStreamer icon
    Select Edit config file
    Change the line where has the port 9090 to 9091
    -> Note the display did not show the config as when you edited it but only with #<comments>
    But once I made that change and went back to Edit config file the display was correct and access the http://localhost:9090 worked! It could just be a fluke of course but worked for me.

    It looks like that it is not reading the mongoose.conf file correctly when the AudioStreamer.exe starts up initially.

    #593

    Lieven Rottiers
    Moderator

    Hi,

    After editing the config file, you should stop and restart AudioStreamer.exe for the changes to have effect.
    You can change the port from 9090 to 9091, but after changing this in the config file you have to stop and start AudioStreamer.exe

    Remark: It is not possible to have 2 instances of AudioStreamer.exe on the same port.
    It’s possible to have 2 instances running, but you have to use another port and you have to create/copy a whole new AudioStreamer folder.

    Hope this helps…
    Regards,
    Lieven

    #595

    busybusy
    Participant

    Lieven,

    I believe that was the case that there was two instances running. This would explain why this mongoose.conf file looks like this:

    # Mongoose web server configuration file.
    # Lines starting with ‘#’ and empty lines are ignored.
    # For detailed description of every option, visit
    # http://code.google.com/p/mongoose/wiki/MongooseManual

    # cgi_extensions .php
    # cgi_environment <value>
    # put_delete_passwords_file <value>
    # cgi_interpreter ./php/php-cgi.exe
    # protect_uri <value>
    # authentication_domain mydomain.com
    # ssi_extensions .shtml,.shtm
    # access_log_file <value>
    # ssl_chain_file <value>
    # enable_directory_listing no
    # error_log_file error.log
    # global_passwords_file <value>
    # index_files index.php
    # enable_keep_alive no
    # access_control_list <value>
    # max_request_size 16384
    # extra_mime_types <value>
    # listening_ports 9091
    # document_root ./core
    # ssl_certificate <value>
    # num_threads 10
    # run_as_user <value>

    Currently I have it running. Thanks!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.