AudioStreamer Forums Support Port forwarded, cannot connect to server unless im connected to my own wifi.

This topic contains 4 replies, has 4 voices, and was last updated by  didotb 2 years, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #620

    Kuromori
    Participant

    How do I fix this? I want to be able to connect via data or other wifi connections.

    #621

    Lieven Rottiers
    Moderator

    Hi,

    Thanks for using AudioStreamer.

    If you are able to use AudioStreamer on your wifi, then as far as AudioStreamer is concerned, everything is running fine.

    I guess you are using AudioStreamer through http://localhost:9090 ?
    Then you should make sure port 9090 is forwarded on your router to the computer on which AudioStreamer is installed. This differs for every router, but is always something like “traffic to 9090” will be forwarded to computer “192.168.0.xxx” (here you need the internal ip-address of the computer).

    To access AudioStreamer from outside, you need the external ip-address of the router.
    You can view this external ip-address via eg: http://ip4.me/ (eg: 123.45.84.89)
    (i’m using the ipv4 ip-address)
    And then access AudioStreamer through http://123.45.84.89:9090

    Hope this helps.

    Regards,
    Lieven

    #745

    ricardob
    Participant

    Lieven,

    I already did such thing ( sorry to get my question here, but is the same as poster) I portforwarded the port and used external ip but no lucl it nver loads anything.

    #746

    Lieven Rottiers
    Moderator

    Hi Ricardo,

    First be sure AudioStreamer works on the pc where you did the install.
    ==>Are you able to run AudioStreamer on the pc where it is installed, through http://localhost:9090 ?

    If that works, then it is something with portforwarding or other security settings in your network.

    Let me know,
    Regards,
    Lieven

    #748

    didotb
    Participant

    check your forwarded ports
    the internal port should be “9090”
    the external port can be anything as long as it’s not interfering with another app using same port. if many people are connected to same network, make sure no one is also using same port.

    next to your browser (any device) go to your ip, and add “:” (colon) then your chosen external port (e.g. 12.345.67.89:8080) Note: if you chose port 80 (http) as your external port you can get away with not putting in the “:*external port*”

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.